import re
regex = re.compile(r"^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Paul Green\n"
"Paul\n"
"Pelè\n"
"paul\n"
"walker\n"
"johnny\n"
"Green")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")