re = /^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)/mi
str = 'Paul Green
Paul
Pelè
paul
walker
johnny
Green'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end