#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\s)\.(?!\s)"
Local $sString = "h.e.ll.o w.o.r.l.d" & @CRLF & _
"=> hello world" & @CRLF & _
"h.e.ll.o w.o.r.l.d" & @CRLF & _
"=> hello world" & @CRLF & _
"hello. world" & @CRLF & _
"=> hello. world"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)