import Foundation
let pattern = #"(?<!\s)\.(?!\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)