import re
regex = re.compile(r"(?<!\s)\.(?!\s)", flags=re.MULTILINE)
test_str = ("h.e.ll.o w.o.r.l.d\n"
"=> hello world\n"
"h.e.ll.o w.o.r.l.d\n"
"=> hello world\n"
"hello. world\n"
"=> hello. world")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)