using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\s)\.(?!\s)";
string substitution = @"";
string input = @"h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}