use strict;
my $str = 'h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world';
my $regex = qr/(?<!\s)\.(?!\s)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";