$re = '/(?<!\s)\.(?!\s)/m';
$str = 'h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;