const regex = new RegExp('(?<!\\s)\\.(?!\\s)', 'gm')
const str = `h.e.ll.o w.o.r.l.d
=> hello world
h.e.ll.o w.o.r.l.d
=> hello world
hello. world
=> hello. world`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);