using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<?=>)|[^[:upper:]+|^ ]";
string substitution = @"\1";
string input = @"aA azee + B => C=";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}