const regex = /(<?=>)|[^[:upper:]+|^ ]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<?=>)|[^[:upper:]+|^ ]', 'g')
const str = `aA azee + B => C=`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);