use strict;
my $str = 'aA azee + B => C=';
my $regex = qr/(<?=>)|[^[:upper:]+|^ ]/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";