#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9-]{5,32}$"
Local $sString = "participantone" & @CRLF & _
"participant1" & @CRLF & _
"Participant1" & @CRLF & _
"participant-1" & @CRLF & _
"participant-one" & @CRLF & _
"participant-one-tn" & @CRLF & _
"Participant1-tn" & @CRLF & _
"Participant-One-tn" & @CRLF & _
"participant.one-tn" & @CRLF & _
"particpant123-456-tn" & @CRLF & _
"participant1.worldwire.io" & @CRLF & _
"participant-1-worldwire-st" & @CRLF & _
"participant-1-worldwire-io-test-test" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")