using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9-]{5,32}$";
string input = @"participantone
participant1
Participant1
participant-1
participant-one
participant-one-tn
Participant1-tn
Participant-One-tn
participant.one-tn
particpant123-456-tn
participant1.worldwire.io
participant-1-worldwire-st
participant-1-worldwire-io-test-test
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}