use strict;
my $str = 'participantone
participant1
Participant1
participant-1
participant-one
participant-one-tn
Participant1-tn
Participant-One-tn
participant.one-tn
particpant123-456-tn
participant1.worldwire.io
participant-1-worldwire-st
participant-1-worldwire-io-test-test
';
my $regex = qr/^[a-zA-Z0-9-]{5,32}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}