// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9-]{5,32}$").unwrap();
let string = "participantone
participant1
Participant1
participant-1
participant-one
participant-one-tn
Participant1-tn
Participant-One-tn
participant.one-tn
particpant123-456-tn
participant1.worldwire.io
participant-1-worldwire-st
participant-1-worldwire-io-test-test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}