import re
regex = re.compile(r"^[a-zA-Z0-9-]{5,32}$", flags=re.MULTILINE)
test_str = ("participantone\n"
"participant1\n"
"Participant1\n"
"participant-1\n"
"participant-one\n"
"participant-one-tn\n"
"Participant1-tn\n"
"Participant-One-tn\n"
"participant.one-tn\n"
"particpant123-456-tn\n"
"participant1.worldwire.io\n"
"participant-1-worldwire-st\n"
"participant-1-worldwire-io-test-test\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")