re = /^[a-zA-Z0-9-]{5,32}$/m
str = 'participantone
participant1
Participant1
participant-1
participant-one
participant-one-tn
Participant1-tn
Participant-One-tn
participant.one-tn
particpant123-456-tn
participant1.worldwire.io
participant-1-worldwire-st
participant-1-worldwire-io-test-test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end