const regex = /^[a-zA-Z0-9-]{5,32}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9-]{5,32}$', 'gm')
const str = `participantone
participant1
Participant1
participant-1
participant-one
participant-one-tn
Participant1-tn
Participant-One-tn
participant.one-tn
particpant123-456-tn
participant1.worldwire.io
participant-1-worldwire-st
participant-1-worldwire-io-test-test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}