#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]+$|[0-9]*:[0-9]+$"
Local $sString = "207.142.131.005" & @CRLF & _
"2001:0db8:0000:08d3:0000:8a2e:0070:7344" & @CRLF & _
"207.142.131.5" & @CRLF & _
"2001:0db8::8d3::8a2e:7:7344" & @CRLF & _
"::1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")