using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+$|[0-9]*:[0-9]+$";
string input = @"207.142.131.005
2001:0db8:0000:08d3:0000:8a2e:0070:7344
207.142.131.5
2001:0db8::8d3::8a2e:7:7344
::1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}