// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]+$|[0-9]*:[0-9]+$").unwrap();
let string = "207.142.131.005
2001:0db8:0000:08d3:0000:8a2e:0070:7344
207.142.131.5
2001:0db8::8d3::8a2e:7:7344
::1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}