package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+$|[0-9]*:[0-9]+$`)
var str = `207.142.131.005
2001:0db8:0000:08d3:0000:8a2e:0070:7344
207.142.131.5
2001:0db8::8d3::8a2e:7:7344
::1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}