$re = '/[0-9]+$|[0-9]*:[0-9]+$/m';
$str = '207.142.131.005
2001:0db8:0000:08d3:0000:8a2e:0070:7344
207.142.131.5
2001:0db8::8d3::8a2e:7:7344
::1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);