import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+$|[0-9]*:[0-9]+$";
final String string = "207.142.131.005\n"
+ "2001:0db8:0000:08d3:0000:8a2e:0070:7344\n"
+ "207.142.131.5\n"
+ "2001:0db8::8d3::8a2e:7:7344\n"
+ "::1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}