use strict;
my $str = '207.142.131.005
2001:0db8:0000:08d3:0000:8a2e:0070:7344
207.142.131.5
2001:0db8::8d3::8a2e:7:7344
::1';
my $regex = qr/[0-9]+$|[0-9]*:[0-9]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}