#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(d(?:-[ab])?|a(?:-b)?|[bc])(/.*)?$"
Local $sString = "a" & @CRLF & _
"a-b" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"d" & @CRLF & _
"d-a" & @CRLF & _
"d-b" & @CRLF & _
"a/text" & @CRLF & _
"a-b/text" & @CRLF & _
"b/text" & @CRLF & _
"c/text" & @CRLF & _
"d/text" & @CRLF & _
"d-a/text" & @CRLF & _
"d-b/text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")