$re = '~^(d(?:-[ab])?|a(?:-b)?|[bc])(/.*)?$~m';
$str = 'a
a-b
b
c
d
d-a
d-b
a/text
a-b/text
b/text
c/text
d/text
d-a/text
d-b/text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);