import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(d(?:-[ab])?|a(?:-b)?|[bc])(/.*)?$";
final String string = "a\n"
+ "a-b\n"
+ "b\n"
+ "c\n"
+ "d\n"
+ "d-a\n"
+ "d-b\n"
+ "a/text\n"
+ "a-b/text\n"
+ "b/text\n"
+ "c/text\n"
+ "d/text\n"
+ "d-a/text\n"
+ "d-b/text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}