// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(d(?:-[ab])?|a(?:-b)?|[bc])(/.*)?$").unwrap();
let string = "a
a-b
b
c
d
d-a
d-b
a/text
a-b/text
b/text
c/text
d/text
d-a/text
d-b/text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}