using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(d(?:-[ab])?|a(?:-b)?|[bc])(/.*)?$";
string input = @"a
a-b
b
c
d
d-a
d-b
a/text
a-b/text
b/text
c/text
d/text
d-a/text
d-b/text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}