re = /^(d(?:-[ab])?|a(?:-b)?|[bc])(\/.*)?$/m
str = 'a
a-b
b
c
d
d-a
d-b
a/text
a-b/text
b/text
c/text
d/text
d-a/text
d-b/text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end