package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(d(?:-[ab])?|a(?:-b)?|[bc])(/.*)?$`)
var str = `a
a-b
b
c
d
d-a
d-b
a/text
a-b/text
b/text
c/text
d/text
d-a/text
d-b/text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}