#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b0?\d{3}\s\d{3}\s\d{3}\b"
Local $sString = "x1: "Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag"" & @CRLF & _
"" & @CRLF & _
"Ex2: "Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag"" & @CRLF & _
"" & @CRLF & _
"Ex3: "Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")