import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0?\\d{3}\\s\\d{3}\\s\\d{3}\\b";
final String string = "x1: \"Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag\"\n\n"
+ "Ex2: \"Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag\"\n\n"
+ "Ex3: \"Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}