// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b0?\d{3}\s\d{3}\s\d{3}\b").unwrap();
let string = "x1: \"Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag\"
Ex2: \"Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag\"
Ex3: \"Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}