re = /\b0?\d{3}\s\d{3}\s\d{3}\b/m
str = 'x1: "Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag"
Ex2: "Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag"
Ex3: "Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end