import re
regex = re.compile(r"\b0?\d{3}\s\d{3}\s\d{3}\b", flags=re.MULTILINE)
test_str = ("x1: \"Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag\"\n\n"
"Ex2: \"Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag\"\n\n"
"Ex3: \"Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")