import Foundation
let pattern = #"\b0?\d{3}\s\d{3}\s\d{3}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
x1: "Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag"
Ex2: "Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag"
Ex3: "Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)