package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b0?\d{3}\s\d{3}\s\d{3}\b`)
var str = `x1: "Phone 18020210 914 171 717 mailbox 43, 1003 Florvaag"
Ex2: "Phone 18020210 N 0914 171 717 mailbox 43, 1003 Florvaag"
Ex3: "Phone 18020210 N0914 171 717 mailbox 43, 1003 Florvaag"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}