#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)mRid:?\s*\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})"
Local $sString = "some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")