re = /mRid:?\s*\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})/i
str = 'some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d'
# Print the match result
str.match(re) do |match|
puts match.to_s
end