use strict;
my $str = 'some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d';
my $regex = qr/mRid:?\s*\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}