const regex = new RegExp('mRid:?\\s*\\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})', 'i')
const str = `some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}