$re = '/mRid:?\s*\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})/i';
$str = 'some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);