import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "mRid:?\\s*\\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})";
final String string = "some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}