package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)mRid:?\s*\[?(?<MRID>[A-F0-9]{8}(?:-[A-F0-9]{4}){3}-[A-F0-9]{12})`)
var str = `some, mrid: [43387658-c5bf-4bfa-a58c-fd65bacbfc3d`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}