# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b((?:id)*)(?=\S)|((?:id)+\b|\b(?<!id))|((?:id)+)/${1:+[}${2:+]}${3:+, }/g;t' <<< "longstringwithid1234andid4321init
id1id2id3
id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
ididid1idid2idid3ididid"