import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:id)*)(?=\\S)|((?:id)+\\b|\\b(?<!id))|((?:id)+)";
final String string = "longstringwithid1234andid4321init\n\n"
+ "id1id2id3\n\n"
+ "id213123213id12321321id\n"
+ "id123421321id12312321id65464\n"
+ "thereisandidanditsnameisbingoidbingoidbingoid2312321\n"
+ "ghjjhghjgd\n"
+ "dsadsadasdsaididididididdsadsadsa\n"
+ "dsa\n"
+ "das id dsadassa id sdadasdsa \n"
+ "idsa2311321id2312312id21321312\n\n"
+ "ididid1idid2idid3ididid";
final String subst = "${1:+[}${2:+]}${3:+, }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}