import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(PJSIP|SIP)\\/(\\d{3,5})-(AA[0-9]{5})";
final String string = "PJSIP/117-AA01002-00000039\n"
+ "SIP/117-AA01002-00000039\n"
+ "SIP/1030-AA01002-00000039\n"
+ "PJSIP/10301-AA01002-00000039\n"
+ "Local/DIAL-8297225031@fromotherpbx-0000004e;2\n"
+ "Local/132-54-0@dialfromfollowme-00000022;2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}